Pinned Posts
Post Title Author Replies Last Reply Info
The Forum feature / improvement sticky
13 Replies
Recently Active Posts
Post Title Author Replies Last Reply Info
GalCiv III Forums - Go To Last Post button doesn't show
0 Replies
Direct link to post issue
3 Replies
Karma not working on Galactic Civilizations III Forums
0 Replies
Cannot Mark all posts as read
5 Replies
Avatar picture not updating on FE forums
6 Replies
Error trying to give karma on forums.galciv3.com
0 Replies
getting message forums are down for maintenance at work
14 Replies
Can't figure out how to unlock "Personal Page"--can't favourite any themes.
5 Replies
[Forum BUG] "Did you know that your Internet Explorer is out of date?"
12 Replies
Forum feedback and suggestions
5 Replies
email expired
8 Replies
Unable to read any forum posts [resolved]
9 Replies
Who's the MOD in charge...
9 Replies
Editing Posts
44 Replies
Forum Changes
44 Replies
Login Issues
7 Replies
Cannot post comment in WB Skins section
33 Replies
Fehlende Dream Upload's
5 Replies
Missing forum features?
134 Replies
"Login" doesn't log into forums and
2 Replies
My Avatar Picture Upload
48 Replies
http://www.elementalgame.com broken
9 Replies
Skins List Issue
6 Replies
Password too long
4 Replies
have windowblinds and can't download anything!
6 Replies
Cannot login in on the Sins of a Solar Empire forums! Help!!!
18 Replies
Long-dead topics keep coming back
35 Replies
Now I can't comment on skins.
12 Replies
Avatar image problems tonight
41 Replies
Reporting PM spam?
3 Replies
Skins List Issue
25 Replies
Adding Comments or Replying to Comments Not Working
17 Replies
Some replys/comments appearing in wrong position?
6 Replies
Error 401 when trying to change profile avatar
15 Replies
forum replies by e-mail ?
1 Replies
[GRIPE] Trying to put together a how-to guide with screenshots is a lot of work ...
6 Replies
Weird Stuff On WinCustomize Forums
22 Replies
WYSIWYG quoting
12 Replies
My Replies link on the fritz
5 Replies
Problem with Metaverse Empire Logo's
22 Replies
Hotmail.com turns to outlook.com
6 Replies
Grey Dead Spaces
28 Replies
Improper site rendering, multiple browsers
13 Replies
Topic "Read" Status Updating Very Sloooowly
5 Replies
Recent posts stuck? Not showing up.
13 Replies
Has anyone noticed that the replies count is off....
4 Replies
Where did the better smileys go?
18 Replies
Change please - SD ads
24 Replies
Pages are whacked....
18 Replies
GalCiv2 site background messed up
10 Replies
10 Pages1 2 3 4 5  Last
Moderators for Forum Issues..
Icon Legend - Click To Show
Stardock Forums v1.0.0.0   #108499   web02  Server Load Time: 00:00:00.0000031  Page Render Time: