"No Serial Number" message after 2.04 Update - can't connect to Metaverse

By on November 10, 2011 6:06:51 PM from Stardock Forums Stardock Forums

Choralone

Join Date 04/2003
0

The day before yesterday I downloaded and installed the 2.04 patch for Galactic Civilizations II - Twilight of the Arnor when it appeared on Impulse. Now I am unable to connect to the Metaverse. When I try, I get a message that "No serial number was found in the registry. You will not be able to submit a game to the metaverse until you register a serial number."

I have used the "View Registration" option in impulse to copy the registration number and past it into the "Update Serial" option in the game's menu, but no luck. I have tried "Re-Activating" the game through Impulse, and get a message that I cannot do so because "the activation file is locked." In the same message I am offered the option to manually remove the activation file, but I can find no such file in the path given C:\ProgramData\Stardock\Twilight\sig.bin.

I posted this to the Impulse forum, and they advised I check with Stardock first. So what are my options - uninstall, dig out my CD, reinstall, re-update, and hope I don't get hosed again by the 2.04 patch? Or find a way to reinstall the game via download instead of using the CD?

60 Replies
Search this post
Subscription Options


Reason for Karma (Optional)
Successfully updated karma reason!
November 10, 2011 7:07:10 PM from GalCiv II Forums GalCiv II Forums

Please contact support@stardock.com about this, they should be able to help.

Reason for Karma (Optional)
Successfully updated karma reason!
November 10, 2011 7:52:19 PM from GalCiv II Forums GalCiv II Forums

I have the same problem.  I've emailed support@stardock.com.

Reason for Karma (Optional)
Successfully updated karma reason!
November 11, 2011 8:13:19 AM from GalCiv II Forums GalCiv II Forums

My game (GalCiv 2 Ultimate edition 2.03) was updated to 2.04 by GameStop client and did not ask for any serial.
PS: Sorry, now I saw that you are talking about Metaverse, I did not tried that.
PS 2: I confirm the problem.
I re-registered the game using my new email address and I still have the same problem.
I think that I registered in the past using other email address.
PS 3: I clicked Update serial and entered my serial in the game menu and after that I was allowed to see the stardock login window.

Reason for Karma (Optional)
Successfully updated karma reason!
November 11, 2011 5:08:09 PM from GalCiv II Forums GalCiv II Forums

Same problen.  I have emailed support@stardock.com

Reason for Karma (Optional)
Successfully updated karma reason!
November 14, 2011 8:00:26 PM from GalCiv II Forums GalCiv II Forums

Received a response from support@stardock.com.  They asked me to open regedit, display a value and send a screenshot of it back to them.

Reason for Karma (Optional)
Successfully updated karma reason!
November 15, 2011 7:11:19 PM from GalCiv II Forums GalCiv II Forums

In response to my request for a solution to the serial number issue I contacted support@stardock.com as recommended - this is the run-around answer I got:

 

"Hello

Stardock Central does not work anymore with game downloads/updates. To download
Gal Civ 2 you will need Impulse.

Due to Impulse now being owned and operated by Gamestop, I have forwarded your
support request to downloadsupport@gamestop.com.



Thank you. ...

Department:
Impulse - Support

Priority: Support

Status: Closed"

 

I already own Gal Civ! The problem is the serial number issue with the metaverse!!

Reason for Karma (Optional)
Successfully updated karma reason!
November 16, 2011 7:41:06 AM from GalCiv II Forums GalCiv II Forums

What was your ticket number?

Reason for Karma (Optional)
Successfully updated karma reason!
November 16, 2011 11:17:35 AM from Stardock Forums Stardock Forums

I have this problem too.

Reformatted Hard Disk then reinstalled GC2, DA, TA from registered Impulse downloads.

I can start and post Metaverse games for GC2 and Dark Avatar but I receive the "No Serial" message for Twilight.

The serial was auto-entered in the Impulse installation process and I have located all serials in my Windows Registry.

Its almost as if the Twilight Metaverse Button is looking somewhere new for the key.

Any workarounds for this yet?

Reason for Karma (Optional)
Successfully updated karma reason!
November 16, 2011 3:56:50 PM from Stardock Forums Stardock Forums

As a workaround, try going to the following registry path:

HKEY_CURRENT_USER\Software\Stardock\Drengin.net\GalCiv2UL

Create a new String Key called "Serial No", and set the value data to your game serial number and see if that helps.

Reason for Karma (Optional)
Successfully updated karma reason!
November 16, 2011 7:47:57 PM from GalCiv II Forums GalCiv II Forums


Here it is:



Ticket Details

Ticket ID: BYP-844068

Department: Impulse - Support

Priority: Support

Status: Closed

Reason for Karma (Optional)
Successfully updated karma reason!
November 16, 2011 8:04:49 PM from GalCiv II Forums GalCiv II Forums

My ticket number is SFX-827584.  I received an email response with the same suggestion that Rosco_P made above.  I tried that, and now GC2 TA will allow me to try to log into the metaverse, but then immediately CTDs.  I sent the debug.err file back to Stardock support.  It seems to indicate (if I'm reading it right) that there are other registry keys that were removed by the 2.04 update in addition to the GalCiv2UL "Serial No".

Reason for Karma (Optional)
Successfully updated karma reason!
November 17, 2011 10:29:20 AM from GalCiv II Forums GalCiv II Forums

Quoting Rosco_P,
As a workaround, try going to the following registry path:

HKEY_CURRENT_USER\Software\Stardock\Drengin.net\GalCiv2UL

Create a new String Key called "Serial No", and set the value data to your game serial number and see if that helps.

I tried to do this, but I wasn't given the option to name it, and I just had a GalCiv2 path, not GalCiv2UL

I do have the same problem - I can't log into the Metaverse due to the game thinking I have no CD key.

Reason for Karma (Optional)
Successfully updated karma reason!
November 17, 2011 2:14:54 PM from GalCiv II Forums GalCiv II Forums

Nobody responds to me from support@stardock.com

 

Sent more then 48 hours ago.

Reason for Karma (Optional)
Successfully updated karma reason!
November 17, 2011 2:35:50 PM from GalCiv II Forums GalCiv II Forums

I went a different route than Rosco_P suggested.

I identified my keys in HKEY_LOCAL_MACHINE...exported the "component manager" entries..

in notepad I changed HKEY_LOCAL_MACHINE to HKEY_CURRENT_USER

then deleted all "component manager" words   (this allows for the keys to be entered as Stardock\Drengin.net)

saved/closed/and doublekickedthe export file

This entered all my keys into HKEY_CURRENT_USER

I have no galciv2UL entry...

I no longer receive the "No Serial" message...I get to put in my login and password...and the software goes to a "connecting to Metaverse" screen...

and then I crash to desktop like Publius.

I vote...ROLLBACK to 2.03...whatever the specific issue addressed by 2.04...wasnt worth it.

Reason for Karma (Optional)
Successfully updated karma reason!
November 18, 2011 3:51:57 PM from GalCiv II Forums GalCiv II Forums

Any update on this? Stardock still hasn't responded to me.

I've now submitted a ticket on their website since they don't seem to ever respond to my emails. Yeah, I know, check the spam filters. But unless they are listed on spamhaus, that is not it. I've also whitellisted *@stardock.com and given them my gmail address. They just will not respond to me via email and its been that way for years, regardless of what host I use or what spam filters are in effect, even when none at all are. I just don't believe its spam filter related at this point.

But enough whining. Any updates on it?

Reason for Karma (Optional)
Successfully updated karma reason!
November 18, 2011 8:15:45 PM from GalCiv II Forums GalCiv II Forums

Quoting TJStriker,
and then I crash to desktop like Publius.

No response today from the debug.err I sent.

Reason for Karma (Optional)
Successfully updated karma reason!
November 18, 2011 9:42:54 PM from GalCiv II Forums GalCiv II Forums

Revisiting the campaigns while I wait...i expect we are the tip of a very large iceberg here...

 

Reason for Karma (Optional)
Successfully updated karma reason!
November 19, 2011 1:26:05 AM from GalCiv II Forums GalCiv II Forums

Quoting TJStriker,
i expect we are the tip of a very large iceberg here...

I regret ever installing the update.  I'm thinking of starting a new metaverse game in DA rather than TA.

Reason for Karma (Optional)
Successfully updated karma reason!
November 19, 2011 2:14:41 AM from GalCiv II Forums GalCiv II Forums

I don't play Metaverse, but this seems pretty disastrous, especially since the entire point of the update was to fix one bug.

Reason for Karma (Optional)
Successfully updated karma reason!
November 20, 2011 11:55:55 AM from GalCiv II Forums GalCiv II Forums

I have the same problem.   So how long do we have to wait for the next real patch?

It works in DA but not in TA. I have all three games that I download from Impluse or Game Stop or Star Dock!!



Edit1: It works in DL too!!

 

We are looking for players to join to be aggressive Admirals to lead my fleets across the Galaxy. 

 

Saint Mina of Ophelia VII ofOrderof the Bloody Rose of Orders Militant ofAdepta Sororita



Reason for Karma (Optional)
Successfully updated karma reason!
November 22, 2011 2:01:28 PM from GalCiv II Forums GalCiv II Forums

is there a way to get the 2.03 download

Reason for Karma (Optional)
Successfully updated karma reason!
November 22, 2011 4:39:40 PM from Stardock Forums Stardock Forums

Here's another fix for you to try:

Download http://sd.stardock.com/gc2_metaverse_remove.zip and extract that to the Twilight directory.
Then remove \ProgramData\stardock\gc2ul\sig.bin
You will need to reactivate but it should work properly after that.
Reason for Karma (Optional)
Successfully updated karma reason!
November 22, 2011 8:55:07 PM from GalCiv II Forums GalCiv II Forums

I tried the Rosco_P recommendation and could not get it to work.  The only sig.bin file is located under the GalCiv2 folder which I dutifully deleted. I do not have a gc2ul folder.  Under Impulse reactivate for Twilight a get message to delete sig.bin under C:\Program Files\Stardock|Twilight.  I don't have that structure - I have: C:\Program Files (x86)\Stardock Games\GalCiv2\Twilight and there is no sig.bin file there.  I still get the missing serial number issue under metaverse.  Arrgh!

Reason for Karma (Optional)
Successfully updated karma reason!
November 23, 2011 2:09:40 AM from GalCiv II Forums GalCiv II Forums

I have tried uninstalling and re-installing but no luck with that.  I mean to be honest I would have thought that a fresh install of TA 2.04 would fix that, but it doesn't.

Reason for Karma (Optional)
Successfully updated karma reason!
November 23, 2011 2:34:54 AM from GalCiv II Forums GalCiv II Forums

So, with the serial number entered in the registry, I clear out my Metaverse folder from the data folder for TA.  When I try to log into the Metaverse again, the folder and the profile stuff inside it is re-created.  So my guess is there is something up with the screen after the login that is casuing the crash.

Reason for Karma (Optional)
Successfully updated karma reason!
Stardock Forums v1.0.0.0    #108433  walnut3   Server Load Time: 00:00:00.0000734   Page Render Time: